Error Message: "The profile has not been set for your user account." on the PanatrackerGP portal when opening a page.

Error Message: "The profile has not been set for your user account." on the PanatrackerGP portal when opening a page.

Symptom

"The profile has not been set for your user account" error appears when opening a page in the PanatrackerGP portal.

On earlier versions of PanatrackerGP, the error message is "Value cannot be null. Parameter name: fileOrServerOrConnection".

Cause

The PanatrackerGP system needs to know which Dynamics GP company to pull data from. Setting the profile provides this information.

Solution

  1. Open the PanatrackerGP portal.
  2. Navigate to User Administration.
  3. Find the username experiencing this error (often Administrator).
  4. Tap Edit on that user's row.
  5. Set the Default Profile to the appropriate profile.
  6. Tap Save.
  7. Log in as the affected user (if you haven't already).
  8. Try accessing the page again.